RSN 14 - EOL Python 3.7 in v22.02

Author RAPIDS TPM
Status

Completed

Topic Platform Support Change
RAPIDS Version v22.02
Created 03 February 2022
Updated 04 February 2022

Overview

Python 3.7 has reached end of life (EOL) in RAPIDS v22.02 and will not be supported in the v22.02 stable release nor the upcoming release of v22.04. This includes v22.02 nightly support which ended on 2022-02-03.

Status

Release support - v22.02

  • Final release of conda packages or docker images supporting Python 3.7

    Nightly support - v22.04

  • No further conda packages or docker images supported for Python 3.7

    Documentation

  • Updates to Docker Hub and NGC repos will be reflected with the v22.02 release
  • Updated rapids.ai release selector to reflect EOL changes and available install options ​

    Impact

    ​ Users should migrate to Python 3.8 or Python 3.9 for RAPIDS.