RSN 26 - Support for 22.10 cuml/cugraph Users

Author RAPIDS Ops
Status

In Progress

Topic Platform Support Change
RAPIDS Version v22.10
Created 14 December 2022
Updated N/A

Overview

RAPIDS 22.10 cuML and cuGraph users will need to add libcusparse<12 libcusolver<=11.4.1.48 to conda install commands for installing cuML or cuGraph.

Example

conda create -n rapids-22.10 -c rapidsai -c conda-forge -c nvidia  cugraph=22.10 python=3.8 cudatoolkit=11.5 libcusparse<12 libcusolver<=11.4.1.48

Impact

Impact is limited to RAPIDS 22.10 cuml and cugraph users.

Background

Since the release of RAPIDS 22.10, some packages that cuML and cuGraph depend on have upgraded and introduced incompatibilities. Conda will install these newer dependencies by default when installing 22.10 cuML or cuGraph, which will result in runtime errors such as:

error while loading shared libraries: libnvJitLink.so.12: cannot open shared object file: No such file or directory

In order to restrict conda to installing only compatible versions of these dependencies, the workaround above should be applied. This workaround is not needed for RAPIDS releases 22.12 and beyond.